Battle Tanks Xmas Edition released!

Good day dear friends! We proudly present the anniversary 16th release of our funny network arcade. In the new version, we have changed… well, everything. Have a look!

First of all, we have released the jerk scripting based on LUA (blames to its inventors).Then, the game balance is fully recalculated:

  • Weapon destruction ranges are reduced.
  • Playing as trooper, you can throw grenades and carry nukes (don’t try that at home!)
  • Rocket launcher can now carry the rocket trooper-beware of angry launchers!
  • Troopers teleport to their carrier if cannot find path.
  • Ther submarine launches nuke missiles.
  • The player can capture empty cars, drive them and USE HORN! When you are in the civilian vehicle, enemy units will not bother you.

Third, we have added The Arena. This is a coop map where you can test almost all weapons against almost all enemies. (BTW, try a new monster on Arena-the Acid Slime.)

Oh well, and of course we have added some killer machines: a bomber helicopter and Chinook that lands troops-they will both hunt you (see them on Arena). Also the new land unit is introduced-a buggy with MG turret; this is the only unit that can shoot down the helicopter. Beware of falling helis!

Also there are changes to deathmatch; we have added there a respawn in random place. And the new sountrack is composed-specially for this release!

The BT team wishes you the Merry Christmas and Happy New Year and offers the Sensational Christmas Discount on Donations: you get 5¢ discount on all donations made before 7th of January next year!*

* — not applicable to donations made through Sourceforge

5647 Responses to “Battle Tanks Xmas Edition released!”

  1. nekr0z Says:

    Так держать! С наступающим! В новогоднюю ночь ожидается глобальное рубилово!

    Или не ожидается… Короче, я там в жалобной книге уже предложение внёс. Если отреагируете до Нового Года, у народа есть шанс пропустить за игрой бой курантов…

  2. VyacheslavS Says:

    С наступающим Новым годом!
    Спасибо за релиз!

    Как ее устанавливать то под линуксом?
    В файле реадми ничего об этом не сказано!

  3. VyacheslavS Says:

    точнее не совсем понятно:
    написано что нужно выполнить с помощью scons,
    но как?
    может FAQ напишете?

  4. umbr1el Says:

    А почему, собсно, ФИ разработчикам ЛУА?

  5. private_face Says:

    VyacheslavS, с помощью scons надо выполнить всего одно действие: набрать в коммандной строке “scons” в папке с игрой. но перед этим необходимо поставить несколько пакетов, указанных в README-linux.txt

  6. private_face Says:

    umbr1el,
    потому, что синтаксис чудовищный. “конкатенация строк” — “..”, “не равно” — “~=” и т.п. оригинальные решения. непонятно, кто мешал разработчикам использовать привычные и всем знакомы конструкции.

    к счастью, достоинства луы перевешивают ее недостатки.

  7. VyacheslavS Says:

    Вы не все необходимые пакеты там указали, в частности для луы - вообще нет инфы, что она нужна.
    Вобщем установил, запустил, работает :)
    Ubuntu 7.10, ATI x1900, Catalyst 7.11.
    Сенкс за игру и еще раз с наступающим!

  8. krovogad Says:

    В моей убунте помогли пакеты луы liblua5.1-0, liblua5.1-0-dev, lua5.1
    Так же пожелание авторам — бубликовать анонсы игры на http://www.happypenguin.org/
    Там много есть хорошего, а этой игры нет почему-то :-)

  9. titi Says:

    can’t build on ubuntu dapper 6.06( yes it’s old but stable)
    I get an error when building.The problem is that the CCFLAGS are surrounded with “”.
    What can I do?


    scons: Building targets …
    g++ -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -fPIC “-O3 -Wall -pedantic -Wno-long-long -pipe -pthread ” -DUSE_GLSDL -DV3_DISABLE_Z -D_REENTRANT -DRELEASE -DBTANKSAPI=DLLEXPORT -DENABLE_LUA -DENABLE_LUA -Ibuild/release -I. -Ibuild/release/src -Isrc -I. -Isrc -c -o build/release/net/message.os net/message.cpp
    cc1plus: error: invalid option argument ‘-O3 -Wall -pedantic -Wno-long-long -pipe -pthread ‘
    scons: *** [build/release/net/message.os] Error 1
    scons: building terminated because of errors.
    tscharn@p60-3000:~/Desktop/btanks-0.7.5800$

  10. iKlim Says:

    Играю в последнюю версию, точнее пытаюсь, на openSUSE 10.3 64 bit. Вылетает постоянно.
    Заметил, что точно вылет, когда беру оружие позволяющее на альтернативном закладывать мины, кажется так, потому что разглядеть не успеваю, тут же вылет.
    И не только из-за этого.

  11. Oksigeno Says:

    Sorry for what? Only about 10% of human population speaks english. Why don\’t you ask for sorry for the other 90% when you post in english?

  12. whoozle Says:

    iKlim, это известная проблема openal. если есть возможность - пересоберите его без поддержки mmx. Но лучше всего, напишите о проблеме в багтракер дистрибутива. это касается тоьлко 64-битной версии. Никакого проигрыша в производительности я не заметил :) (я собирал deb пакеты)

  13. titi Says:

    Ich könnte ja auch auf deutsch posten, ob das allerdings beser ist weiss ich auch nicht.
    ( I can also post in english but I don\’t know if this is better )

    or in french:
    Je peut aussi ecrir en francais mais je suis pas sur si c\’est mieux?

    But please help me (whoever knows a solution)
    Aber bitte helft mir, wenn ihr eine Lösung wisst.
    Mais si tu sais un solution, aider mois.

    ok now we have more than 10%, please help me.

    Titi

  14. Alinaki Says:

    А может кто-нибудь подсказать, как сгенерировать deb пакет под убунту 7.10? sudo checkinstall scons генерирует 17ти килобайтный файл…. Просто scons ничего не устанавливает по человечески, а просто компилит в той же папке. Играть конечно можно, но хотелось бы человеческой установки :)

  15. whoozle Says:

    titi. post your problem in english please.

  16. whoozle Says:

    Alinaki, в следующем релизе будет один файл с ресурсами и всё станет много проще для всех. Видимо нормальные пакеты будут только со следующего релиза :(
    Если очень хочется - возьмите спеки от дебиана (sid), добавте lua и перегенерите список ресурсов

  17. whoozle Says:

    titi, try upgrading scons, it’s a known issue. :(

  18. fullmetalcoder Says:

    I got a little problem when trying to build Battle Tanks :

    fullmetalcoder[btanks-0.7.5800]$ scons
    scons: Reading SConscript files …
    Checking for sigc::signal1 sig in C++ library sigc-2.0… yes
    Checking for XML_ParserCreate(NULL) in C library expat… yes
    Checking for zlibVersion() in C library z… yes
    Checking for SDL_Init(0) in C++ library SDL… yes
    Checking for IMG_Load(0) in C++ library SDL_image… yes
    Checking for ALuint s; alGenSources(1, &s) in C++ library openal… yes
    Checking for ov_open(0, 0, 0, 0) in C++ library vorbisfile… yes
    version: 0.7.5800
    Exception: Cannot find lua5.1/lua5.0 or lua pkg-config information:
    File \\\\

  19. zx-net Says:

    Ура, на мандриве 2008 free lce начало собираться :)
    пришлось вытягивать из инета около 35!!! зависимых пакетов.
    Чтобы облегчить поиск зависимых пакетов, выкладываю линк
    http://mandriva.c3sl.ufpr.br/official/2008.0/i586/media/main/release/

  20. zx-net Says:

    Лезут ошибки:
    scons: building associated BuildDir targets: build/release
    g++ -o build/release/src/window.os -c -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -fPIC -O3 -Wall -pedantic -Wno-long-long -pipe -pthread -DUSE_GLSDL -DV3_DISABLE_Z -D_REENTRANT -DRELEASE -DBTANKSAPI=DLLEXPORT -DENABLE_LUA -DENABLE_LUA -Ibuild/release -I. -Ibuild/release/src -Isrc -I. -Isrc src/window.cpp
    In file included from src/window.cpp:34:
    /usr/include/SDL/SDL_opengl.h:44:60: error: GL/gl.h: No such file or directory
    /usr/include/SDL/SDL_opengl.h:45:58: error: GL/glu.h: No such file or directory
    scons: done building targets.

    src/window.cpp:297: error: ‘GL_VENDOR’ was not declared in this scope
    src/window.cpp:298: error: ‘GL_RENDERER’ was not declared in this scope
    scons: *** [build/release/src/window.os] Error 1
    scons: building terminated because of errors.

    В чем проблема может быть?

  21. zx-net Says:

    Поставил mesa пакеты “из коробки” и сборка продолжилась…

  22. whoozle Says:

    fullmetalcoder, install lua5.1 devel packages, liblua5.1-0, liblua5.1-0-dev, lua5.1 for debian/ubuntu

  23. Pirat Says:

    scons: *** [build/release/net/message.os] Error 1
    Вот такая ошибка при установке
    ASPLinux 11.2 без обновлений.

  24. Max Says:

    scons: *** [build/release/mrt/utf8_utils.os] Error

    Linux zen 2.6.25.4 #1 SMP PREEMPT Fri May 16 14:10:46 CEST 2008 i686 AMD Sempron(tm) Processor 3000+ AuthenticAMD GNU/Linux

Leave a Reply

You must be logged in to post a comment.